Verification is currently underway for the maintenance items.
Posted Apr 05, 2024 - 06:51 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 05, 2024 - 06:00 UTC
Scheduled
Please be advised that a critical maintenance session has been scheduled, impacting all Be My Eyes services. This essential maintenance will take place on April 5th and is expected to last for one hour, commencing at 06:00 UTC (8:00 CEST / 2am EDT). We appreciate your understanding and apologize for any inconvenience this may cause.